
1672605   06/2009
16
72

60
5

www.schneider-electric.com

TeSys U Modbus
Quick Start Guide
 

06/2009



 

Schneider Electric assumes no responsibility for any errors that may appear in this document. If you have any 
suggestions for improvements or amendments or have found errors in this publication, please notify us. 

No part of this document may be reproduced in any form or by any means, electronic or mechanical, 
including photocopying, without express written permission of Schneider Electric.

All pertinent state, regional, and local safety regulations must be observed when installing and using this 
product. For reasons of safety and to help ensure compliance with documented system data, only the 
manufacturer should perform repairs to components.

When devices are used for applications with technical safety requirements, the relevant instructions must 
be followed. 

Failure to use Schneider Electric software or approved software with our hardware products may result 
in injury, harm, or improper operating results.

Failure to observe this information can result in injury or equipment damage.

© 2009 Schneider Electric. All rights reserved.
2 1672605 06/2009



Table of Contents
About the Book . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Chapter 1 Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

Presentation of the Application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
The Schneider Electric Solution with Tesys U Motor Starter. . . . . . . . . . . . . . . . . . . . . . . . . . . 6

Chapter 2 Setting Up TeSys U. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
LUCA12BL and LUCD18BL Settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
LULC033 Connectors, and Address Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Chapter 3 Setting Up Communication Network to a PLC. . . . . . . . . . . . . . . . . . . . . . 11
3.1 Configuring TeSys U on the Modbus Network with Unity Pro (for a Premium PLC) . . . . . . 12
3.2  Configuring TeSys U on the Modbus Network with Unity Pro (for an M340 PLC) . . . . . . . 14
3.3 Configuring DFBs with the Application  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
1672605 06/2009 3



4

About the Book
At a Glance

Document Scope

The Quick Start Guide uses an application example to describe the different steps to quickly install, 
configure, and control TeSys U motor starters. With this Quick Start Guide, you can easily set up a 
Modbus communication network, provided that you have a basic knowledge in PLCs and application 
software (Unity Pro). You do not need any other document to perform this task. 

For more details about other capabilities of TeSys U motor starters, consult the related documents listed below.

Related Documents

You can download these technical publications and other technical information from our website at 
www.schneider-electric.com.

User Comments

We welcome your comments about this document. You can reach us by e-mail at techcomm@schneider-
electric.com.

Title of Documentation Reference Number

TeSys U LULC032-033 Modbus Communication Module - User’s Manual 1743234

TeSys U Communication Variables - User’s Manual 1744082

TeSys U LUB/LUS Starters - Instruction Sheet 1629984

TeSys U LUCA/LUCB/LUCC/LUCD Control Units - Instruction Sheet AAV40503

TeSys DFB Offer - User Manual 1672600
 1672605 06/2009



1672605 06/2009
1

Introduction

1672605   06/2009
Introduction 
What's in this Chapter?

This chapter contains the following topics:

Presentation of the Application

Introduction

The application example helps you to define Direct On Line (D.O.L.) motor starters step by step, in order to: 
provide thermal magnetic protection,
control the motor, and
obtain contactor feedback and circuit breaker trip feedback.

Description of the Application

Motor 1 (M1):
3-phase motor, class 10, 5.5 kW (7.5 hp) at 440 V, 50 Hz, rated current In = 10.5 A, D.O.L. 
Motor 2 (M2):
3-phase motor, class 20, 7.5 kW  (10 hp) at 440 V, 50 Hz, rated current In = 14.7 A, D.O.L. with remote 
monitoring of motor load.

Traditional Solution

The scheme below shows wiring in the traditional solution: all control and feedback information is wired 
through a PLC.

Topic Page
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Introduction
The Schneider Electric Solution with Tesys U Motor Starter

Power and Control Schemes in the Schneider Electric Solution

Control Units Used in the Schneider Electric Solution

The Schneider Electric solution presented in this Quick Start Guide uses TeSys U to meet different client needs.

LUCA12BL is a standard control unit used with motor 1 for basic needs:
control a motor remotely (start/stop)
provide status information (ready, running, fault condition)

LUCD18BL is an advanced control unit used with motor 2 for advanced needs, in addition to the 
standard ones:

warning
automatic and remote reset via the bus
indication of the motor load
differentiation of faults

Power Scheme Control Scheme

1. TSX SCY 11601 Modbus master coupler with 
integrated port for RS 485
2. LU9GC3 splitter box with 8 RJ45 connectors for bus 
connection to LULC033 module and screw terminals 
(24 V)
3. LU9BN11L prewired coil connection
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Introduction
Architecture of the TeSys U System

The following architecture describes the main components of the TeSys U system mounted on a plate:

Legend Commercial Reference Description

1+2+3+4 Premium Programmable Logic Controller (PLC) including 3 modules: power 
supply (1), processor (2), and communication (3) on a rack (4)

1 TSX PSY 5500M Premium power supply module

2 TSX P57 354M Premium processor

3 TSX SCY 11601 Premium communication module including 1 sub-D 25 connector

4 TSX RKY 6 Premium single rack (6 positions), enabling all Premium modules to be 
mechanically and electrically fitted.

5 TSX SCY CM6030 3 m (10 ft) cable equipped with a 25-pin SUB-D connector and stripped at the 
other end

6 LU9GC3 Splitter box with 10 RJ45 connectors (8 for node connections) and 1 screw 
terminal (24 V)

7 VW3 A8 306 RC Line terminator

8 LUB12 TeSys U power base

9 LUCA12BL Standard control unit

10, 13 LULC033 Modbus communication module

11 LUB32 TeSys U power base

12 LUCD18BL Advanced control unit

14 VW3 A8 306 R10 1 m (3.3 ft) cable with 2 RJ45 connectors

15 LU9BN11L Prewired coil connection (optional), or

16 (standard connection 
coming with LULC033)

Plug-in terminal block, for wire-to-wire control of A1/A2 terminals

1 2 3 4 8 119 105

12

13

16 15

14

6 7
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Introduction
Software Tools

The following software tools must be used to set the applications. Their use requires a basic knowledge.

Network Conditions

Protocol: Modbus

Baud Rate: 19,200 bps

Data bits: 8

Stop bit: 1

Parity: even

Addresses:
1 for TeSys U motor 1
2 for TeSys U motor 2

Commercial Reference Freeware Description

UNY SPU EFP CD40 – Unity Pro Extra Large V4.0 (and later versions) programming 
software for Premium PLC.

UNY SPU EFM CD40 – Unity Pro Extra Large V4.0 (and later versions) programming 
software for M340 PLC.

– DFB library including  
Ctrl_cmd_mdb_u_add•

TeSys U control/command for Modbus SL. Download the TeSys U 
DFB library from the www.schneider-electric.com website.
8 1672605 06/2009
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Setting up TeSys U
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Setting Up TeSys U
What's in this Chapter?

This chapter contains the following topics:

LUCA12BL and LUCD18BL Settings

Setting Current on the Control Units

The figure below shows how to set current on the control unit using a screwdriver (LUCA12BL here):

Current Setting Values

The table below shows the settings for LUCA12BL (Standard Control Unit) and LUCD18BL (Advanced 
Control Unit):

Topic Page

LUCA12BL and LUCD18BL Settings 9

LULC033 Connectors, and Address Settings 10

4.00A

LUCA / LUCD

LULC033

5.00A

7.00A

9.00A

12.0A

3.00A

TeSys

LUCA 12BL

24V c

CLASS 10

3 a

Control Unit Motor Current Setting Range Motor Nominal Power Current Setting Value =
Motor Rated Current

LUCA12BL M1 3..12 A 5.5 kW (7.5 hp) 10.5 A

LUCD18BL M2 4.4..18 A 7.5 kW (10 hp) 14.7 A
9



Setting up TeSys U
LULC033 Connectors, and Address Settings

Presentation

Use the DIP switches, under the LULC033 communication module, to set the Modbus address.

1 RJ45 connector
2 Input/Output terminal block and 24 Vdc
3 Address

Address

Assign an address from 1 to 31, using the 5 switches (SW1 to SW5). Address 0 (zero) is not allowed and 
is considered as an invalid configuration.

In the application, addresses are 1 and 2:

SW5 SW4 SW3 SW2 SW1 Address

0 0 0 0 1 1 (default value)

0 0 0 1 0 2

Address 1 for TeSys U Motor 1 Address 2 for TeSys U Motor 2

SW5 SW4 SW3 SW2 SW1

on

off

SW5 SW4 SW3 SW2 SW1

on

off
10 1672605 06/2009
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Setting Up Communication Network to a PLC
Introduction

This chapter describes how to set communication to a PLC step by step using Unity Pro software. The 
PLC can be:

Premium, or
Modicon M340

What's in this Chapter?

This chapter contains the following topics:

Topic Page

3.1 Configuring TeSys U on the Modbus Network with Unity Pro (for a Premium PLC) 12

3.2  Configuring TeSys U on the Modbus Network with Unity Pro (for an M340 PLC) 14

3.3 Configuring DFBs with the Application 16
11



Setting Up Communication Network to a PLC
3.1 Configuring TeSys U on the Modbus Network with Unity Pro (for a Premium PLC)

Configuration Process for a Premium PLC

Configuring the Application Network

Configuration steps with Unity Pro XL software are as follows:

Step Action

1 Start Unity Pro XL V4.0 software.

2 Configure the Premium PLC for Modbus:
From the File menu, create a new project.
In the New Project window, expand the Premium list and select TSX P57 354M.
Confirm by clicking OK.

3 From the Structural view of the Project Browser, select Configuration → 0 : PLC bus → 
0 : TSX RKY 6, and then double-click to see the configuration: 
12 1672605 06/2009



Setting Up Communication Network to a PLC
Performing Functional Testing of the Communication Network

To test the configuration, wiring, and communication with Unity Pro XL software proceed as follows:

4 Double-click the master coupler device to open the Configuration window:

Check for the following values:
1. Type: Master
2. Baud rate: 19 200 bits/s
3. Data: RTU (8 bits)
4. Stop: 1 bit
5. Parity: even

5
Select Edit → Validate, or click  to validate the configuration. 

6 Select Build → Rebuild all project to rebuild the project. If the values are correct (no error), the NOT 
BUILT state changes to BUILT.

7 Save your application as an .STU file.

8 Connect the appropriate programming cable from your PC to the Premium PLC.

9 Power up the Premium PLC.

10 Click Connect in Unity Pro XL.

11 Click the PLC menu: the Transfer Project To PLC window opens. Click the Transfer button.

12 Click the Run icon.

Step Action

Step Action

1 From the Structural view of the Project Browser, select your configuration.

2 In the Configuration window, select the Debug tab.

3 In Channel test, select the slave number 1 and click on the Identification button.

4 A pop-up window opens and should display that the exchange is OK. The LED COMM of the TeSys U 
blinks once for each Identification request received.
1672605 06/2009 13



Setting Up Communication Network to a PLC
3.2  Configuring TeSys U on the Modbus Network with Unity Pro (for an M340 PLC)

Configuration Process for a Modicon M340 PLC

Configuring the Application Network

Configuration steps with Unity Pro XL software are as follows:

Step Action

1 Start Unity Pro XL V4.0 software.

2 Configure the Modicon M340 PLC for Modbus:
From the File menu, create a new project.
In the New Project window, expand the Modicon M340 list and select BMX P34 2010.
Confirm by clicking OK.

3 From the Structural view of the Project Browser, select Configuration → 0 : PLC bus → 
0 : BMX XBP 0600, and then double-click to see the configuration: 
14 1672605 06/2009



Setting Up Communication Network to a PLC
Performing Functional Testing of the Communication Network

To test the configuration, wiring, and communication with Unity Pro XL software proceed as follows:

4 Double-click the master coupler device to open the Configuration window:

Check for the following values:
1. Type: Master
2. Baud rate: 19 200 bits/s
3. Data: RTU (8 bits)
4. Stop: 1 bit
5. Parity: even

5
Select Edit → Validate, or click  to validate the configuration. 

6 Select Build → Rebuild all project to rebuild the project. If the values are correct (no error), the NOT 
BUILT state changes to BUILT.

7 Save your application as an .STU file.

8 Connect the appropriate programming cable from your PC to the M340 PLC.

9 Power up the M340 PLC.

10 Click Connect in Unity Pro XL.

11 Click the PLC menu: the Transfer Project To PLC window opens. Click the Transfer button.

12 Click the Run icon.

Step Action

Step Action

1 From the Structural view of the Project Browser, select your configuration.

2 In the Configuration window, select the Debug tab.

3 In Channel test, select the slave number 1 and click on the Identification button.

4 A pop-up window opens and should display that the exchange is OK. The LED COMM of the TeSys U 
blinks once for each Identification request received.
1672605 06/2009 15



Setting Up Communication Network to a PLC
3.3 Configuring DFBs with the Application

Presentation

The TeSys DFB (Derived Function Blocks) offer has been developed to simplify and optimize the 
integration of TeSys U starter-controllers in PLC applications.

The Ctrl_cmd_mdb_u_add• DFBs are dedicated to the control and command of a single TeSys U starter-
controller (up to 32 A/15 kW or 20 hp) with any control unit and an LULC033 Modbus communication 
module through the Modbus SL (Serial Line) network.

The Ctrl_cmd_mdb_u_add• DFBs are:
Ctrl_cmd_mdb_u_addr, which uses XWAY addressing and is dedicated to Premium PLCs,
Ctrl_cmd_mdb_u_addm, which uses a different addressing method and is dedicated to M340 PLCs.

1. Downloading the DFB Files
2. Installing DFB in Unity Pro
3. Fetching Your Project and DFB Application in Unity Pro

For more information, see the TeSys DFB Offer User manual.

1) Downloading the DFB Files

The following table describes the steps to follow to download the TeSys DFB offer from the 
www.schneider-electric.com website:

2) Installing DFB in Unity Pro

Step Action

1 Open the Schneider Electric website: www.schneider-electric.com

2 Click Products and Services, and then click Automation and Control.

3 In the Downloads section of the left menu bar, click Current offers

4 In the Choose a function drop-down list, select Motor Control.
In the Choose a range drop-down list, select TeSys U.
In the Choose a type of document drop-down list, select Software/Firmware.

Click >Find.

5 Select TeSys DFB offer package and download the zip file on your hard disk.

6 Extract the TeSys DFB offer package.zip file content to a single directory on your hard disk. 2 directories, 
PL7 Pro and Unity Pro, will be created, each of them containing the following folders:

Step Action

1
From  Start button, All Programs menu, browse to Schneider Electric → Unity Pro → Types 
Library Update.

2 In the Types Library Update window, browse to 04 Cyclic control command  → FAMILY.DSC and 
open it. 
NOTE: The application version you select must be compliant with Unity Pro.

3 Click the Install family button. A pop-up window appears, with the following message: “The installation 
has succeeded”. Then, exit.
16 1672605 06/2009



Setting Up Communication Network to a PLC
3) Fetching Your Project and DFB Application in Unity Pro

Step Action

1 Start Unity Pro software.

2 Open the DFB section of a program. From Edit menu, get Data Selection... sub-menu.
An empty Function Input Assistant window opens. First item is FFB type. Browse to get the 
Ctrl_cmd_mdb_u_add• Modbus DFB: Ctrl_cmd_mdb_u_addm in this example. The following window opens:

Confirm with OK.

3 The Function Input Assistant window now displays your selection:
1672605 06/2009 17



Setting Up Communication Network to a PLC
Input Characteristics

The following table describes the Ctrl_cmd_mdb_u_add• DFB inputs and their availability according to 
the control unit:

4 The DFB graphical representation for Ctrl_cmd_mdb_u_addm is displayed:

NOTE: The content of Ctrl_cmd_mdb_u_addr is identical.

5 To operate Ctrl_cmd_mdb_u_addr DFB for a Premium PLC, you must configure the public variables. In 
this application, they are at least the slot number (slot_num) and the rack number (rack_num):

To operate Ctrl_cmd_mdb_u_addm DFB for an M340 PLC, use the default values for this application.

Step Action

Input Type Range Default Value Description LUCA LUCD

Slav_num INT 1...31 1 Modbus slave number √ √

Prog_num INT 1...30 – See Program Number, page 19 √ √

Rst_cmd EBOOL 0...1 0 Reset command √ √

Strt_cmd EBOOL 0...1 0 Start command √ √

Run_fwd EBOOL 0...1 0 Motor run forward command √ √

Run_rev EBOOL 0...1 0 Motor run reverse command √ √

Rst_flt EBOOL 0...1 0 Reset device (if register 451 = 102 or 104, 
fault acknowledgment causes a return to 
communication module factory settings)

√ √

Rst_warn EBOOL 0...1 0 Reset warning (for example, communication 
loss)

√ √

Ther_ov EBOOL 0...1 0 Automatic thermal overload fault test – –

Trip_tst EBOOL 0...1 0 Overcurrent trip test via communication bus –  –

In_word INT – – This input is only used when program number 
is 10, 20, or 30. See next table and program 
number description.

– –
18 1672605 06/2009



Setting Up Communication Network to a PLC
The following table describes the In_word input:

Program Number

The program number enables the user to select bit or word control.

The following table describes the programs of the DFB:

Output Characteristics

The following table describes the Ctrl_cmd_mdb_u_add• DFB outputs and their availability according to 
the control unit:

Input Type Bit Description LUCA LUCD

In_word INT 0 Motor run forward command √ √

1 Motor run reverse command √ √

2 Reserved – –

3 Reset device (if register 451 = 102 or 104, fault 
acknowledgment causes a return to communication module 
factory settings)

√ √

4 Reserved – –

5 Automatic thermal overload fault test – –

6 Overcurrent trip test via communication bus – –

7 Reserved – –

8 Reset warning (for example, communication loss) √ √

9...15 Reserved – –

Program Number Description

1 Read registers 455 and 456, then write register 704 (systematic)

2 Read registers 455 and 456, then write register 704 (conditional)

3 Write register 704

10 Same as program 1 but using the In_word input and the Out_word output

20 Same as program 2 but using the In_word input and the Out_word output

30 Same as program 3 but using the In_word input and the Out_word output

Output Type Range Default Value Description LUCA LUCD

Fault_st EBOOL 0...1 0 Fault detected √ √

Rst_st EBOOL 0...1 0 Reset state √ √

End_st EBOOL 0...1 0 End state √ √

Ready EBOOL 0...1 0 System ready: the rotary handle is turned to On 
position and there is no fault

√ √

Closed EBOOL 0...1 0 Pole status: closed √ √

Fault EBOOL 0...1 0 All faults √ √

Alarm EBOOL 0...1 0 All warnings √ √

Tripped EBOOL 0...1 0 System tripped: the rotary handle is turned to Trip position √ √

Rst_auth EBOOL 0...1 0 Fault reset authorized – √

Starting EBOOL 0...1 0 Start in progress:
0 = descending current is lower than 150 % FLA
1 = ascending current is greater than 10 % FLA

– √

Running EBOOL 0...1 0 Motor running with detection of current, if greater 
than 10 % FLA

– √

Avg_curr INT 0...200 0 Average motor current (x 1 % FLA) – √

Out_word INT – – This output is only used when program number is 10, 20, 
or 30. See next table and program number description.

–  
1672605 06/2009 19



Setting Up Communication Network to a PLC
The following table describes the Out_word output:

Public Variables Characteristics

The following table describes the Ctrl_cmd_mdb_u_addr DFB public variables using XWAY addressing 
and their availability according to the control unit:

The following table describes the Ctrl_cmd_mdb_u_addm DFB public variables using M340 addressing 
and their availability according to the control unit:

Output Type Bit Description LUCA LUCD

Out_word INT 0 System ready: the rotary handle is turned to On position and there 
is no fault.

√ √

1 Pole status: closed √ √

2 All faults √ √

3 All warnings √ √

4 System tripped: the rotary handle is turned to Trip position. √ √

5 Fault reset authorized – √

6 Reserved – –

7 Motor running with detection of current, if greater than 10% FLA – √

8...13 Average motor current (% FLA)
32 = 100% FLA
63 = 200% FLA

– √

14 Reserved – –

15 Start in progress:
0 = descending current is lower than 150% FLA
1 = ascending current is greater than 10% FLA

– √

Public Variable Type Range Default Value Description LUCA LUCD

Net_num INT 100...255 0 Network address √ √

Stat_num INT 0...255 0 Station address √ √

Rack_num INT 0...7 0 Destination rack address √ √

Slot_num INT 0...10 0 Destination slot address √ √

Chan_num INT 0...1 0 Destination channel address √ √

Sq_princ INT 0...7 0 Reserved for support √ √

Public Variable Type Range Default Value Description LUCA LUCD

Rack_num INT 0...7 0 Destination rack address √ √

Slot_num INT 0...10 0 Destination slot address √ √

Chan_num INT 0...1 0 Destination channel address √ √

IP_addr1 INT 0...255 0 First byte of IP address √ √

IP_addr2 INT 0...255 0 Second byte of IP address √ √

IP_addr3 INT 0...255 0 Third byte of IP address √ √

IP_addr4 INT 0...255 0 Fourth byte of IP address √ √

Sq_princ INT 0...7 0 Reserved for support √ √
20 1672605 06/2009



Setting Up Communication Network to a PLC
Programming DFB (= M1) for Motor 1

Step Action

1 Link the Run_fwd M1 input to the motor 1 start condition.

2 Link the M1 outputs to PLC variables for use in the program:
Closed M1 output = position of the KM1 contactor
Tripped M1 output = tripped position of the Q1 TeSys U

3 Check that M1, for Motor 1, displays as follows:

1 Not applicable
2 Applicable but not used; can be managed by the PLC application

NOTE: The content of Ctrl_cmd_mdb_u_addr is identical.
1672605 06/2009 21



Setting Up Communication Network to a PLC
Programming DFB (= M2) for Motor 2

Step Action

1 Link the Run_fwd M2 input to the motor 2 start condition.

2 Link the M2 outputs to PLC variables for use in the program:
Closed M2 output = position of the KM2 contactor
Tripped M2 output = tripped position of the Q2 TeSys U

3 Link the Avg_curr M2 output to a PLC register for use of motor 2 average current in the program.

4 Check that M2, for Motor 2, displays as follows:

1 Not applicable
2 Applicable but not used; can be managed by the PLC application

NOTE: The content of Ctrl_cmd_mdb_u_addr is identical.
22 1672605 06/2009
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