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About the Book
At a Glance

Document Scope

The Quick Start Guide uses an application example to describe the different steps to quickly install, 
configure, and control TeSys U motor starters. With this Quick Start Guide, you can easily set up a 
Profibus DP communication network, provided that you have a basic knowledge in PLCs and application 
software (Unity Pro, Sycon, ...). You do not need any other document to perform this task. 

For more details about other capabilities of TeSys U motor starters, consult the related documents listed below.

Related Documents

You can download these technical publications and other technical information from our website at 
www.schneider-electric.com.

User Comments

We welcome your comments about this document. You can reach us by e-mail at techcomm@schneider-electric.com.

Title of Documentation Reference Number

TeSys U LULC07 Profibus DP Communication Module - User’s Manual 1672610

TeSys U Communication Variables - User’s Manual 1744082

TeSys U LUB/LUS Starters - Instruction Sheet 1629984

TeSys U LUCA/LUCB/LUCC/LUCD Control Units - Instruction Sheet AAV40503

TeSys DFB Offer - User Manual 1672600

TeSys U LULC07 Profibus DP Communication Module - Beginner’s Guide 1672611

TeSys U LULC07 Profibus DP Communication Module - Application Note 1672612
 1672606 06/2009
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Introduction 
What's in this Chapter?

This chapter contains the following topics:

Presentation of the Application

Introduction

The application example helps you to define Direct On Line (D.O.L.) motor starters step by step, in order to: 
provide thermal magnetic protection,
control the motor, and
obtain contactor feedback and circuit breaker trip feedback.

Description of the Application

Motor 1 (M1):
3-phase motor, class 10, 5.5 kW (7.5 hp) at 440 V, 50 Hz, rated current In = 10.5 A, D.O.L. 
Motor 2 (M2):
3-phase motor, class 20, 7.5 kW  (10 hp) at 440 V, 50 Hz, rated current In = 14.7 A, D.O.L. with remote 
monitoring of motor load.

Traditional Solution

The scheme below shows wiring in the traditional solution: all control and feedback information is wired 
through a PLC.

Topic Page

Presentation of the Application 5

The Schneider Electric Solution with Tesys U Motor Starter 6
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M1

5.5 kW

440 V 50 Hz

KM1

M2

Q1 Q2

7.5 kW

KM2
5



Introduction
The Schneider Electric Solution with Tesys U Motor Starter

Power and Control Schemes in the Schneider Electric Solution

Control Units Used in the Schneider Electric Solution

The Schneider Electric solution presented in this Quick Start Guide uses TeSys U to meet different client 
needs.

LUCA12BL is a standard control unit used with motor 1 for basic needs:
control a motor remotely (start/stop)
provide status information (ready, running, fault condition)

LUCD18BL is an advanced control unit used with motor 2 for advanced needs, in addition to the 
standard ones:

warning
automatic and remote reset via the bus
indication of the motor load
differentiation of faults

Power Scheme Control Scheme

1. TSX PBY 100 Profibus DP master coupler including a 
PCMCIA board, cable and a tap
2. LU9GC7 splitter box with 2 sub-D 9 connectors (bus 
connection to LULC07 module) and screw terminals 
(24 V)
3. LU9BN11L prewired coil connection

A
1

A
2

LUCAppBL

5.5 kW

Q1
KM1

M1

440 V 50 Hz

TeSys U TeSys U

A
1

A
2

A
1

A
2

A
1

A
2

LUCDppBL

LULC07

Profibus DP
bus
24 Vdc

Profibus DP
bus
24 Vdc

LULC07

7.5 kW

Q2
KM2

M2

24 Vdc 24 Vdc

LU9GC7

IN OUT

24V DC

Modicon TSX

Interface 1
PROFIBUS
RS485

Interface 2
host

490 NAE 911 00
PROFIBUS-TAP

2

3 3

LUCDppLUCApp

LULC07 LULC07

TeSys UTeSys U

1
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Introduction
Architecture of the TeSys U System

The following architecture describes the main components of the TeSys U system mounted on a plate:

Legend Commercial Reference Description

1+2+3+4 Premium Programmable Logic Controller (PLC) including 3 modules: power 
supply (1), processor (2), and PCMCIA (3) on a rack (4)

1 TSX PSY 5500M Premium power supply module

2 TSX P57 354M Premium processor

3 TSX PBY 100 Premium PCMCIA module including:
a host module for the PCMCIA board,
a Profibus DP PCMCIA board with its integral connecting cable, 0.6 m 
(2 ft) long, and
a 490 NAE 911 00 Profibus tap with 1 female sub-D 9 (left) connector 
and 1 male sub-D 15 (right) connector

4 TSX RKY 6 Premium single rack (6 positions), enabling all Premium modules to be 
mechanically and electrically fitted

5 490 NAD 911 03 (or 04) Connector

6 TSX PBSCA100 100 m (328 ft) cable, to be cut according to the network size

7 LU9GC7 Splitter box with 2 sub-D 9 connectors (bus connection) and screw terminals 
(24 V)

8 LUB12 TeSys U power base

9 LUCA12BL Standard control unit

10, 13, 17 LULC07 Profibus DP communication module with plug-in terminal block, for wire-to-
wire control of A1/A2 terminals

11 LUB32 TeSys U power base

12 LUCD18BL Advanced control unit

14 LU9AD7 Connector for daisy chaining connection
Slave 1 connector line termination = OFF
Slave 2 connector line termination = ON

15 TSX PBS 100 100 m (328 ft) cable, to be cut according to the network size

16 LU9BN11L Prewired coil connection (optional)

1 2 3 54 6 7 8 119 10

14

15

12

13

17 16
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Introduction
Software Tools

The following software tools must be used to set the applications. Their use requires a basic knowledge.

Network Conditions

Protocol: Profibus DP

Baud Rate: 1,500 kbps

Addresses:
1 for TeSys U motor 1
2 for TeSys U motor 2

Fallback Strategy:

In case of a communication loss with the PLC, the fallback strategy offers the possibility to operate a 
motor in different ways. Set parameter 682 to one of the following values:

The fallback strategy adapted to the application is:
Value 1 = Frozen for motor 1
Value 2 = Forced stop for motor 2

Commercial Reference Freeware Description

UNY SPU EFP CD40 – Unity Pro Extra Large V4.0 programming software for 
Premium PLC.

SYCSPULFUCD29M – Sycon V2.9 network configuration software for Premium 
PLC (single user license). 

– DFB library, including  
Ctrl_pfb_u_ms

TeSys U cyclic control/command for Profibus DP MS. 
Download the TeSys U DFB library from the 
www.schneider-electric.com website.

Parameter 682 Value Fallback Mode Description

0 Disabled No strategy is applied. This is not recommended.

1 Frozen On detection of a communication loss, the motor will keep its status:
If running, the motor will keep running.
If stopped, the motor will remain stopped.

No change in control status is authorized. A new control will be 
considered only after a communication loss reset (703.3).

2 Forced stop 
(default value)

The motor is forced to stop.
Output OA1 = 0
Output OA3 = 0

3 Unchanged Changes in control status are authorized. A new control will be 
considered even before a communication loss reset (703.3).

4 Forced to run forward Output OA1 = 1 (direct) 
Output OA3 = 0

5 Forced to run reverse Output OA1 = 0
Output OA3 = 1 (reversing)
8 1672606 06/2009
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Setting Up TeSys U
What's in this Chapter?

This chapter contains the following topics:

LUCA12BL and LUCD18BL Settings

Setting Current on the Control Units

The figure below shows how to set current on the control unit using a screwdriver (LUCA12BL here):

Current Setting Values

The table below shows the settings for LUCA12BL (Standard Control Unit) and LUCD18BL (Advanced 
Control Unit):

Topic Page

LUCA12BL and LUCD18BL Settings 9

LULC07 Connectors, and Address Settings 10

4.00A

LUCA / LUCD

LULC07

5.00A

7.00A

9.00A

12.0A

3.00A

TeSys

LUCA 12BL

24V c

CLASS 10

3 a

Control Unit Motor Current Setting Range Motor Nominal Power Current Setting Value = 
Motor Rated Current

LUCA12BL M1 3..12 A 5.5 kW (7.5 hp) 10.5 A

LUCD18BL M2 4.4..18 A 7.5 kW (10 hp) 14.7 A
9



Setting up TeSys U
LULC07 Connectors, and Address Settings

Presentation

Use the DIP switches, under the LULC07 communication module, to set the Profibus DP address.

1 Profibus DP sub-D 9 connector
2 Input/Output terminal block and 24 Vdc
3 Address

Address

Assign an address from 1 to 127, using the 7 right most switches (SW1 to SW7). Address 0 (zero) is not 
allowed and is considered an invalid configuration.

In the application, addresses are 1 and 2:

321

LO1LI1LI2
24V c

VP
P24

RxD/TxD-N

M24
RxD/TxD-P CNTR-P

DGND

SW7 SW6 SW5 SW4 SW3 SW2 SW1 Address

0 0 0 0 0 0 1 1 (default value)

0 0 0 0 0 1 0 2

Address 1 for TeSys U Motor 1 Address 2 for TeSys U Motor 2

SW7 SW6 SW5 SW4 SW3 SW2 SW1

on

off

SW7 SW6 SW5 SW4 SW3 SW2 SW1

on

off
10 1672606 06/2009
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Setting Up Communication Network to a PLC
Introduction

This chapter describes how to set communication to a Premium PLC step by step, using:
Unity Pro, and
Sycon.

What's in this Chapter?

This chapter contains the following topics:

Topic Page

3.1 Configuring TeSys U on the Profibus DP Network with Unity Pro and Sycon 12

3.2. Configuring DFBs with the Application 18
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Setting Up Communication Network to a PLC
3.1 Configuring TeSys U on the Profibus DP Network with Unity Pro and Sycon

Configuration Process for a Premium PLC

1)  Downloading the GSD Files

The following table describes the steps to follow to download the GSD and icon files associated to 
Tesys U from the www.schneider-electric.com website:

Step Action

1 Open the Schneider Electric website: www.schneider-electric.com.

2 Click Products and Services, and then click Automation and Control.

3 In the Downloads section of the left menu bar, click Current offers.

4 In the Choose a function drop-down list, select Motor Control.
In the Choose a range drop-down list, select TeSys U.
In the Choose a type of document drop-down list, select Software/Firmware.

Click >Find.

5 Select Communication Module TeSys U PROFIBUS LULC07 and download 
LULC07_GSD_DIB_files_V100.exe file.

6 Double-click LULC07_GSD_DIB_files_V100.exe on your hard disk. Click Accept in the ‘Licence for 
software downloaded from Schneider-Electric web sites’ window which opens, and then browse for a 
destination folder and click Install.

7 Select the GSD file: TELE094C.GSD
12 1672606 06/2009



Setting Up Communication Network to a PLC
2)  Configuring the Application Network

The first configuration steps with Unity Pro XL software are described below:

Step Action

1 Start Unity Pro XL V4.0 software.

2 Configure your Premium PLC and communication accessories (PCMCIA card, etc.):

3 Save your application as an .STU file.

4 Double-click the TSX PBY 100 coupler. The PROFIBUS-DP MODULE Configuration window opens: 

You may not need to edit it. 
To continue the configuration process, click on the Sycon (hilscher) button. If it is not displayed, install 
Sycon software again.
1672606 06/2009 13



Setting Up Communication Network to a PLC
Continue the configuration process with Sycon software, as described below:

Step Action

1 In Sycon V2.9 software, click File → New.

2 In the Select fieldbus dialog, choose Profibus DP and validate.

3 Import your LULC07 GSD file by clicking File → Copy GSD.

4 Browse until you find the TELE094C.GSD file.

5 Insert a master: 
click Insert → Master..., or

select  

6 Double-click the Setting menu and select Master Configuration: the Auto addressing box is default 
checked. It means that you will not have to edit the input and output addresses for nodes 1 and 2. If you 
uncheck the box, you will have to edit the node addresses.
 
In the Insert Master window, select TSX PBY 100 from the Available masters list. Click the Add>> 
button. Enter an address in Station address, e.g. 10. 

Confirm with OK.

7 Insert a node: 
click Insert → Slave..., or

select 

8 In the Insert Slave window, select LULC07 - TeSys U Profibus from the Available slaves list: 

Slave 1 is at address 1. Slave 2 is at address 2. 

9 To set the bus parameter, select the master on screen, and then click Settings → Bus Parameter:

Select the Baudrate at 1500 kBits/s and confirm with OK.
14 1672606 06/2009



Setting Up Communication Network to a PLC
10 Double-click a node to open the Slave Configuration window:

From the Module list, select:
Sc_St_R_MS for Slave1
Sc_Ad_R_MS for Slave2

Where abbreviations stand for... 
Sc: Starter-controller, 
St: Standard control unit, and Ad: Advanced control unit,
R: Remote control,
MS: Motor Starter.

NOTE: To shift from Slave1 to Slave2, you can either do it from this window, changing slaves in the 
Actual slave box, or go to the tree structure and double-click Slave2. 

11 To define a communication loss fallback strategy, click the Parameter Data button. In the 
Parameter Data window, click the Module button.
Select the first line of the list and set the communication loss fallback strategy from the drop-down list: 

Freeze outputs for slave 1
Force stop for slave 2

Confirm with OK.

12 Save your configuration by clicking File → Save as. Your configuration file will have a .PB extension. 
Convert your file to an ASCII format by clicking File → Export → ASCII, for use in Unity Pro.
Quit Sycon software.

Step Action
1672606 06/2009 15



Setting Up Communication Network to a PLC
 

Complete the configuration process with Unity Pro XL software, in the PROFIBUS-DP MODULE 
Configuration window: 

Step Action

1 NOTE: In the Configuration window, (1), (2) and (3) correspond to actions to perform in steps 1, 2, and 3.

Click the Load CNF button and open the .CNF file.

2 Change the default Diagnostic Length, along with the Diagnostic Telegram for Profibus DP information 
contained in TeSys U LULC07 Profibus DP User’s Manual:

Default value (in bytes) = 32
New value = 36

3 To optimize the memory size, set the No. of IW/QW from the drop-down list:
Default value = 128
New value = 32

4
Select Edit → Validate, or click  to validate the configuration. 

5 Select Build → Rebuild all project.
16 1672606 06/2009



Setting Up Communication Network to a PLC
3)  Performing Functional Testing of the Communication Network Including Premium PLC and Products 

Step Action

1 Connect the appropriate programming cable from your PC to the Premium PLC.

2 Power up the Premium PLC.

3 Click Connect.

4 From the PLC menu, transfer the project.

5 Power up the 2 TeSys U systems, and then click Run. 
At that stage, the communication is established correctly: red BF communication status LED is off, and green 
24V LED is on. However, if the red ERR fault LED is blinking, it means that the communication has been lost.

6 The PROFIBUS-DP MODULE window has a Debug tab. The tables below are extracted from this tab, 
with the addresses containing the cyclic exchanges per equipment. Name the variables in such a way to 
avoid programming with names which do no provide any information on the contents of the memory 
location (e.g. Ready_M1 instead of %IW0.3.0).

In case of a communication fault at a slave’s level, the corresponding line in the PROFIBUS-DP slave 
configuration list displays in red, and an explanation message appears in the PROFIBUS-DP diagnostic box.
Cyclically exchanged data appears in the Value column.
1672606 06/2009 17



Setting Up Communication Network to a PLC
3.2. Configuring DFBs with the Application

Presentation

The TeSys DFB (Derived Function Blocks) offer has been developed to simplify and optimize the 
integration of TeSys U starter-controllers in PLC applications.

The Ctrl_pfb_u_ms DFB is dedicated to the control and command of a single TeSys U starter-controller 
(up to 32 A/15 kW or 20 hp) through the Profibus DP MS (Motor Starter) network.

1. Downloading the DFB Files
2. Installing DFB in Unity Pro
3. Fetching Your Project and DFB Application in Unity Pro

For more information, see the TeSys DFB Offer User manual.

1) Downloading the DFB Files

The following table describes the steps to follow to download the TeSys DFB offer from the 
www.schneider-electric.com website:

2) Installing DFB in Unity Pro

Step Action

1 Open the Schneider Electric website: www.schneider-electric.com

2 Click Products and Services, and then click Automation and Control.

3 In the Downloads section of the left menu bar, click Current offers

4 In the Choose a function drop-down list, select Motor Control.
In the Choose a range drop-down list, select TeSys U.
In the Choose a type of document drop-down list, select Software/Firmware.

Click >Find.

5 Select TeSys DFB offer package and download the zip file on your hard disk.

6 Extract the TeSys DFB offer package.zip file content to a single directory on your hard disk. 2 directories, 
PL7 Pro and Unity Pro, will be created, each of them containing the following folders:

Step Action

1
From  Start button, All Programs menu, browse to Schneider Electric → Unity Pro → 
Types Library Update.

2 In the Types Library Update window, browse to 04 Cyclic control command  → FAMILY.DSC and 
open it. 
NOTE: The application version you select must be compliant with Unity Pro.

3 Click the Install family button. A pop-up window appears, with the following message: “The installation 
has succeeded”. Then, exit.
18 1672606 06/2009



Setting Up Communication Network to a PLC
3) Fetching Your Project and DFB Application in Unity Pro

Step Action

1 Start Unity Pro software.

2 Open the FBD section of a program. From Edit menu, get Data Selection... sub-menu. 
An empty Function Input Assistant window opens. First item is FFB type. Browse to get the 
Profibus DFB: Ctrl_pfb_u_ms. The following window opens:

Confirm with OK.

3 The Function Input Assistant window now displays your selection:

Confirm with OK.

4 The DFB graphical representation is displayed:
1672606 06/2009 19



Setting Up Communication Network to a PLC
Input Characteristics

The following table describes the DFB inputs and their availability according to the control unit:

Output Characteristics

The following table describes the DFB outputs and their availability according to the control unit:

Input Type Range Default Value Description LUCA LUCD

Ms_in1 INT _ 0 To link to the first word of the MS Profibus slave 
input cyclic data

√ √

Run_fwd EBOOL 0...1 0 Motor run forward command √ √

Run_rev EBOOL 0...1 0 Motor run reverse command √ √

Rst_flt EBOOL 0...1 0 Reset fault (in case of a communication module 
internal fault, Reset fault resets the 
communication module to factory settings)

√ √

Rst_warn EBOOL 0...1 0 Reset warning (for example, communication loss) √ √

Em_strt EBOOL 0...1 0 Emergency start (resets the thermal memory)   

Trip_tst EBOOL 0...1 0 Overcurrent trip test via communication bus   

Output Type Range Default Value Description LUCA LUCD

Ms_out1 INT _ 0 To link to the first word of the MS Profibus slave 
output cyclic data

√ √

Ready EBOOL 0...1 0 System ready: the rotary handle is turned to the 
On position and no faults detected

√ √

Closed EBOOL 0...1 0 Pole status: closed √ √

Tripped EBOOL 0...1 0 System tripped: the rotary handle is turned to Trip 
position

√ √

Fault EBOOL 0...1 0 All faults √ √

Alarm EBOOL 0...1 0 All warnings √ √

Rst_auth EBOOL 0...1 0 Fault reset authorized  √

Starting EBOOL 0...1 0 Start-up in progress:
1 = ascending current is greater than 10 % FLA
0 = descending current is lower than 150 % FLA

 √

Running EBOOL 0...1 0 Motor running with detection of current, if greater 
than 10 % FLA

 √

Avg_curr INT 0...200 0 Average motor current (% FLA)  √
20 1672606 06/2009



Setting Up Communication Network to a PLC
Programming DFB (= M1) for Motor 1

Step Action

1 Link the Run_fwd input to the motor 1 start condition.

2 Link the M1 outputs to PLC variables for use in the program:
Closed M1 output = position of the KM1 contactor
Tripped M1 output = tripped position of the Q1 TeSys U

3 Check that M1, for Motor 1, displays as follows:

1 Not applicable
2 Applicable but not used; can be managed by the PLC application
1672606 06/2009 21



Setting Up Communication Network to a PLC
Programming DFB (= M2)  for Motor 2

Step Action

1 Link the Run_fwd M2 input to the motor 2 start condition.

2 Link the M2 outputs to PLC variables for use in the program:
Closed M2 output = position of the KM2 contactor
Tripped M2 output = tripped position of the Q2 TeSys U

3 Link the Avg_curr M2 output to a PLC register for use of motor 2 average current in the program.

4 Check that M 2, for Motor 2, displays as follows:

1 Not applicable
2 Applicable but not used; can be managed by the PLC application
22 1672606 06/2009
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